<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US">
<![endif]-->
<!--[if (!IE)]><!-->
<html lang="en-US">
<!--<![endif]-->

<head>
<meta charset="UTF-8" />
<title>Ferndale Rep’s “Little Shop of Horrors” is a must-see musical | The Ferndale Enterprise</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="http://www.ferndaleenterprise.com/xmlrpc.php" />

<!-- All in One SEO Pack 2.3.2.3 by Michael Torbert of Semper Fi Web Design[-1,-1] -->
<link rel="canonical" href="http://www.ferndaleenterprise.com/2017/10/09/ferndale-reps-little-shop-of-horrors-is-a-must-see-musical/" />
<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Ferndale Enterprise &raquo; Feed" href="http://www.ferndaleenterprise.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Ferndale Enterprise &raquo; Comments Feed" href="http://www.ferndaleenterprise.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Ferndale Enterprise &raquo; Ferndale Rep’s “Little Shop of Horrors” is a must-see musical Comments Feed" href="http://www.ferndaleenterprise.com/2017/10/09/ferndale-reps-little-shop-of-horrors-is-a-must-see-musical/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.ferndaleenterprise.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.6"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='coraline-css'  href='http://www.ferndaleenterprise.com/wp-content/themes/coraline/style.css?ver=4.7.6' type='text/css' media='all' />
<link rel='stylesheet' id='slickr-flickr-css'  href='http://www.ferndaleenterprise.com/wp-content/plugins/slickr-flickr/styles/public.css?ver=2.5.4' type='text/css' media='all' />
<link rel='stylesheet' id='slickr-flickr-lightbox-css'  href='http://www.ferndaleenterprise.com/wp-content/plugins/slickr-flickr/styles/lightGallery.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='http://www.ferndaleenterprise.com/wp-includes/css/dashicons.min.css?ver=4.7.6' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='http://www.ferndaleenterprise.com/wp-includes/js/thickbox/thickbox.css?ver=4.7.6' type='text/css' media='all' />
<link rel='stylesheet' id='galleria-classic-css'  href='http://www.ferndaleenterprise.com/wp-content/plugins/slickr-flickr/galleria/themes/classic/galleria.classic.css?ver=1.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://www.ferndaleenterprise.com/wp-content/plugins/jetpack/css/jetpack.css?ver=3.9.7' type='text/css' media='all' />
<script type='text/javascript' src='http://www.ferndaleenterprise.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.ferndaleenterprise.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://www.ferndaleenterprise.com/wp-content/plugins/slickr-flickr/scripts/lightGallery.min.js?ver=1.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"http:\/\/www.ferndaleenterprise.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.ferndaleenterprise.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105'></script>
<script type='text/javascript' src='http://www.ferndaleenterprise.com/wp-content/plugins/slickr-flickr/galleria/galleria-1.4.2.min.js?ver=1.4.2'></script>
<script type='text/javascript' src='http://www.ferndaleenterprise.com/wp-content/plugins/slickr-flickr/galleria/themes/classic/galleria.classic.min.js?ver=1.4.2'></script>
<script type='text/javascript' src='http://www.ferndaleenterprise.com/wp-content/plugins/slickr-flickr/scripts/responsiveslides.min.js?ver=1.54'></script>
<script type='text/javascript' src='http://www.ferndaleenterprise.com/wp-content/plugins/slickr-flickr/scripts/public.js?ver=2.5.4'></script>
<link rel='https://api.w.org/' href='http://www.ferndaleenterprise.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.ferndaleenterprise.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.ferndaleenterprise.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Council fast tracks marijuana ordinance' href='http://www.ferndaleenterprise.com/2017/10/09/council-fast-tracks-marijuana-ordinance/' />
<link rel='next' title='Three Ferndale residents witness Vegas slaughter' href='http://www.ferndaleenterprise.com/2017/10/10/three-ferndale-residents-witness-vegas-slaughter/' />
<meta name="generator" content="WordPress 4.7.6" />
<link rel='shortlink' href='http://wp.me/p2OYln-r3' />
<link rel="alternate" type="application/json+oembed" href="http://www.ferndaleenterprise.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.ferndaleenterprise.com%2F2017%2F10%2F09%2Fferndale-reps-little-shop-of-horrors-is-a-must-see-musical%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.ferndaleenterprise.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.ferndaleenterprise.com%2F2017%2F10%2F09%2Fferndale-reps-little-shop-of-horrors-is-a-must-see-musical%2F&#038;format=xml" />
	<style type="text/css">
			#site-title,
		#site-description {
			position: absolute;
			left: -9000px;
		}
		</style>
	<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #ffffff; }
</style>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Ferndale Rep’s “Little Shop of Horrors” is a must-see musical" />
<meta property="og:url" content="http://www.ferndaleenterprise.com/2017/10/09/ferndale-reps-little-shop-of-horrors-is-a-must-see-musical/" />
<meta property="og:description" content="From the October 5 print edition By Emily Silver Enterprise arts editor SKID ROW DREAMIN’ Skid. Row. Vagrants hanging out idly among dilapidated empty buildings? Vacant lots? Seedy taverns? The plo…" />
<meta property="article:published_time" content="2017-10-09T19:24:33+00:00" />
<meta property="article:modified_time" content="2017-10-09T19:25:00+00:00" />
<meta property="og:site_name" content="The Ferndale Enterprise" />
<meta property="og:image" content="https://s0.wp.com/i/blank.jpg" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:card" content="summary" />
</head>

<body class="post-template-default single single-post postid-1677 single-format-standard custom-background three-column sidebar-content-sidebar">
<div id="container" class="hfeed contain">
	<div id="header">
		<div id="masthead" role="banner">
						<div id="site-title">
				<span>
					<a href="http://www.ferndaleenterprise.com/" title="The Ferndale Enterprise" rel="home">The Ferndale Enterprise</a>
				</span>
			</div>
			<div id="site-description">It&#039;s all about us</div>
		</div><!-- #masthead -->

		<div id="access" role="navigation">
		  			<div class="skip-link screen-reader-text"><a href="#content" title="Skip to content">Skip to content</a></div>
						<div class="menu-header"><ul id="menu-main-menu" class="menu"><li id="menu-item-353" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-353"><a href="http://www.ferndaleenterprise.com/">Home</a></li>
<li id="menu-item-354" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-354"><a href="http://www.ferndaleenterprise.com/advertise/">Advertise</a></li>
<li id="menu-item-368" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-368"><a href="http://www.ferndaleenterprise.com/subscribe/">Subscribe</a></li>
<li id="menu-item-358" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-358"><a href="http://www.ferndaleenterprise.com/contact/">Contact</a></li>
<li id="menu-item-377" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-377"><a href="http://www.ferndaleenterprise.com/newsstands/">Newsstands</a></li>
<li id="menu-item-355" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-355"><a href="http://www.ferndaleenterprise.com/archives/">Archives</a></li>
<li id="menu-item-364" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-364"><a href="http://www.ferndaleenterprise.com/merchandise/">Merchandise</a></li>
<li id="menu-item-366" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-366"><a href="http://www.ferndaleenterprise.com/souvenir-edition/">Souvenir Edition</a></li>
<li id="menu-item-371" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-371"><a href="http://www.ferndaleenterprise.com/about/">About</a>
<ul class="sub-menu">
	<li id="menu-item-356" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-356"><a href="http://www.ferndaleenterprise.com/awards/">Awards</a></li>
	<li id="menu-item-360" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-360"><a href="http://www.ferndaleenterprise.com/history/">History</a></li>
	<li id="menu-item-367" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-367"><a href="http://www.ferndaleenterprise.com/staff/">Staff</a></li>
</ul>
</li>
<li id="menu-item-361" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-361"><a href="http://www.ferndaleenterprise.com/in-the-news/">In the news</a></li>
<li id="menu-item-363" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-363"><a href="http://www.ferndaleenterprise.com/jack/">Jack&#8217;s Corner</a>
<ul class="sub-menu">
	<li id="menu-item-1233" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1233"><a href="http://www.ferndaleenterprise.com/jack/jack-mays-editorial-cartoon-awards/">Awards</a></li>
	<li id="menu-item-384" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-384"><a href="http://www.ferndaleenterprise.com/jack/gallery/">Gallery</a></li>
</ul>
</li>
<li id="menu-item-365" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-365"><a href="http://www.ferndaleenterprise.com/podcast/">Podcast</a></li>
<li id="menu-item-357" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-357"><a href="http://www.ferndaleenterprise.com/blog/">Blog</a></li>
</ul></div>		</div><!-- #access -->

		<div id="branding">
						<a href="http://www.ferndaleenterprise.com/">
									<img src="http://www.ferndaleenterprise.com/wp-content/uploads/2012/04/990x180maxheight.gif" width="990" height="180" alt="" />
							</a>
					</div><!-- #branding -->
	</div><!-- #header -->

	<div id="content-box">

<div id="content-container">
	<div id="content" role="main">

	
		<div id="nav-above" class="navigation">
			<div class="nav-previous"><a href="http://www.ferndaleenterprise.com/2017/10/09/council-fast-tracks-marijuana-ordinance/" rel="prev"><span class="meta-nav">&larr;</span> Council fast tracks marijuana ordinance</a></div>
			<div class="nav-next"><a href="http://www.ferndaleenterprise.com/2017/10/10/three-ferndale-residents-witness-vegas-slaughter/" rel="next">Three Ferndale residents witness Vegas slaughter <span class="meta-nav">&rarr;</span></a></div>
		</div><!-- #nav-above -->

		<div id="post-1677" class="post-1677 post type-post status-publish format-standard hentry category-blog">

			
			<h1 class="entry-title">Ferndale Rep’s “Little Shop of Horrors” is a must-see musical</h1>
							<div class="entry-meta">
					<span class="meta-prep meta-prep-author">Posted on</span> <a href="http://www.ferndaleenterprise.com/2017/10/09/ferndale-reps-little-shop-of-horrors-is-a-must-see-musical/" title="12:24 pm" rel="bookmark"><span class="entry-date">October 9, 2017</span></a> <span class="by-author"><span class="sep">by</span> <span class="author vcard"><a class="url fn n" href="http://www.ferndaleenterprise.com/author/theferndaleenterprise/" title="View all posts by The Ferndale Enterprise" rel="author">The Ferndale Enterprise</a></span> </span><span class="comments-link"><span class="meta-sep">|</span> <a href="http://www.ferndaleenterprise.com/2017/10/09/ferndale-reps-little-shop-of-horrors-is-a-must-see-musical/#respond">Leave a comment</a></span>
									</div><!-- .entry-meta -->
			
			<div class="entry-content">
				<p><strong>From the October 5 print edition</strong></p>
<p><strong>By Emily Silver </strong></p>
<p><strong><em>Enterprise</em> arts editor </strong></p>
<p style="text-align: center;"><strong>SKID ROW DREAMIN’ </strong></p>
<p>Skid. Row. Vagrants hanging out idly among dilapidated empty buildings? Vacant lots? Seedy taverns? The plot and themes of “Little Shop of Horrors,” currently in production at Ferndale Repertory Theatre, depend heavily on the idea of transcending Skid Row. Mushnick’s Flower Shop is peopled by characters such as the disillusioned Mushnick himself (played straightforwardly here by Warren W. Hardison), his rescue-project Seymour, and Audrey the desperate salesgirl. Their only wealth is hope. And, it turns out, a carnivorous plant.</p>
<p style="text-align: center;"><strong>LOOKING BACK </strong></p>
<p>In 1960, Roger Corman had wrapped up shooting for his “Bucket of Blood,” but he still had some time before his sets were dismantled. A quick brainstorm with “Chuck” Griffith and Sally Kellerman yielded a plot to fit the set and “Little Shop of Horrors” was born. Corman employed Jonathan Haze for Seymour and a young Jack Nicholson (back when he had hair) as a pain-loving dental patient. The black and white film was produced in two days and eventually outshone “Bucket of Blood” in popularity. The musical premiered in New York in 1982 with Howard Ashman’s book and lyrics and music by Alan Menken, and the 1986 film featured Steve Martin, Rick Moranis, and Ellen Greene.</p>
<p style="text-align: center;"><strong>ALL SKID ROW’S THE STAGE </strong></p>
<p>The complex set expertly designed by Cecilia Beaton and painted by Raymond Gutierrez emphasizes depth and makes for dynamic staging. Our view is a cross section of the shop from within; the door of the shop opens beneath a bridge. The tall towers of the city are lit by a changing sky at stage right (lighting by Michael Foster). Closer to us downstage boarded-up doorways, stoops, and a fire escapes provide vertical interest.</p>
<p style="text-align: center;"><strong>FEED ME </strong></p>
<p>Who buys flowers on Skid Row? Mushnick’s shop seems destined for failure. But when the product of Seymour’s plant experiments, Audrey II, is displayed in the window, suddenly customers begin to flock in. Success is in the air, but at what price? The plant swells ominously each time she’s fed. A sequence of fleshy puppets, created by Intermission Productions (“You Dream It, We Seam It”), is effectively manipulated by stage combat expert Jeff Cooper. And yes, the plant speaks and sings the blues in a rockin’ bass voiced by Craig Woods.</p>
<p style="text-align: center;"><strong>FEARLESS </strong></p>
<p>This is Alexandra Blouin’s debut as a director. Her multi-faceted talents were evident in “Boeing! Boeing,” “Bat Boy,”  and “Beauty and the Beast” among others and she brings them together successfully here. Blouin’s dedicated discipline is evident in her ability to handle the layered concerns of this musical: a complicated set, constantly changing lighting, choreography, music, and puppets. Not to mention inspiring the actors. And deciding how to deal with graphic violence. Nothing to worry about. Skillfully, Blouin has refrained from overrunning the production with violence. While the maleficent plant enlists Seymour to hack folks up so she can “grow,” we’re spared the view of the hacking. Only a few fake bloody body parts show up onstage. Considering whose they’re meant to be, we’re glad to see it.</p>
<p style="text-align: center;"><strong>DOES IT HURT? </strong></p>
<p>Lucius Robinson is a quintessential bad guy. While Steve Martin tackled the role of Orin Scrivello, D.D.S. in the 1986 film version, I honestly can’t imagine a more quintessentially evil “Doctor” than Robinson’s. Raising frowning eyebrows, pulling up to a grotesque grin, cutting loose with that sinister laugh, and gesturing with the dental drill all help the audience anticipate his demise. Later, Robinson morphs comfortably into brief “other roles,” demonstrating tremendous versatility and costume-change agility, most memorably when he appears in drag as a Life magazine rep.</p>
<p style="text-align: center;"><strong>“LITTLE SHOPPA HORRAS / BOP-SH’BOP” </strong></p>
<p>Audrey II starts getting lively with blood from a mere finger-prick, but her increasing appetite augurs poorly for all the characters– except, thankfully, the three sirens Ronette (Emma Johnstone), Chiffon (Jessie Rawson), and Crystal (Stevie-Alexis Maquez). From the very first moment, this Greek-style chorus enlivens every scene with their bright costumes (way too fashionable for Skid Row, really) and ironic commentaries. Introducing themselves as fifth-grade dropouts, wielding cigarettes and Brooklyn accents, Johnstone, Rawson, and Maquez convey wonderful style and unity, in part thanks to their flashy costumes designed by costume mistress Cindy Shepard. Their lusty voices synchronize perfectly with the accompanying piano licks by Laura Welch. Individual “head things” and Elvis sneers spark their performances in a campy way.</p>
<p style="text-align: center;"><strong>AUDREY ONE </strong></p>
<p>Jessica Kaufman as Audrey personifies longing and a vision for a better life. She dresses impeccably and dates a dentist who beats her up. She also helps locate the play in the 1960s, idealizing Levittown, Lucy, Donna Reed, Howdy Doody, and living in a tract home in the ironic ballad “Somewhere That’s Green.”</p>
<p style="text-align: center;"><strong>SUDDENLY SEYMOUR </strong></p>
<p>Poor little Seymour is dwarfed by Audrey. As played by Morgan Cox, he’s content to be pathetic: “I started life as an orphan, a child of the street here on skid row,” he sings. Mushnick “took me in, gave me shelter, a bed, . . . and a job. Treats me like dirt, calls me a slob. . .which I am.” With his almost liquid facial muscles, receding chin, timid stature, and light tenor voice I can’t imagine anyone nailing Seymour better than Cox–not surprising since Cox has aimed for this role ever since he was nine. It’s uncanny what a great fit it is.</p>
<p style="text-align: center;"><strong>THE UNSEEN </strong></p>
<p>It’s a challenge to synchronize and tune up even a house orchestra with what’s going on onstage. And never mind that the voice and movements of one of the characters are covered by separate actors. Music and Vocal Directors David Powell and Laura Welch are nowhere to be seen, but they create a powerful presence. Welch’s invisible piano is audible in a big way without dominating, and the actors’ voices are aligned with it seemingly miraculously.</p>
<p style="text-align: center;"><strong>OH MY THE REMODEL </strong></p>
<p>Regular visitors to Ferndale Repertory Theatre will note this summer’s remodel has transformed and modernized the interior. Improvements include a roomy new concession area, video screens identifying the players in the lobby, and new seating with clear sightlines and, best of all . . . cup holders! The new sound system enables actors to wear almost-invisible mics. Many thanks to The Kurt Feuerman Foundation, Ferndale Rotary Club, the McLean Foundation, and many private donors for funding this upgrade.</p>
<p style="text-align: center;"><strong>“THE WAY THE WORLD IS. . .” </strong></p>
<p>“Little Shop of Horrors” is another in a sequence of productions that showcases Ferndale Repertory Theatre as a go-to source for satisfying musical theatre. We’re so lucky to have them on the North Coast. As Tim Curry said, “The way the world is, I think a silly evening in the theatre is a good thing, to take our minds off terror.” “Little Shop of Horrors,” plays now through October 29 on Fridays, Saturdays, and Sundays at 447 Main in Ferndale. Check out their website at www.ferndalerep.org or call them at 707-786-5483.</p>
<div style="float: right; margin-bottom: 10px; margin-right: 0px;"><a href="http://twitter.com/share?url=http://www.ferndaleenterprise.com/2017/10/09/ferndale-reps-little-shop-of-horrors-is-a-must-see-musical/&via=FrndEnterprise&text=Ferndale Rep’s “Little Shop of Horrors” is a must-see musical&related=FrndEnterprise:&lang=en&count=horizontal" class="twitter-share-button">Tweet</a><script type="text/javascript" src="http://platform.twitter.com/widgets.js"></script></div>							</div><!-- .entry-content -->

			<div class="entry-info">
							This entry was posted in <a href="http://www.ferndaleenterprise.com/category/blog/" rel="category tag">Blog</a>. Bookmark the <a href="http://www.ferndaleenterprise.com/2017/10/09/ferndale-reps-little-shop-of-horrors-is-a-must-see-musical/" title="Permalink to Ferndale Rep’s “Little Shop of Horrors” is a must-see musical" rel="bookmark">permalink</a>.							</div><!-- .entry-info -->
		</div><!-- #post-## -->

		<div id="nav-below" class="navigation">
			<div class="nav-previous"><a href="http://www.ferndaleenterprise.com/2017/10/09/council-fast-tracks-marijuana-ordinance/" rel="prev"><span class="meta-nav">&larr;</span> Council fast tracks marijuana ordinance</a></div>
			<div class="nav-next"><a href="http://www.ferndaleenterprise.com/2017/10/10/three-ferndale-residents-witness-vegas-slaughter/" rel="next">Three Ferndale residents witness Vegas slaughter <span class="meta-nav">&rarr;</span></a></div>
		</div><!-- #nav-below -->

		
<div id="comments">

	
			<p class="nocomments">Comments are closed.</p>
		
	
	
</div><!-- #comments -->
	
	</div><!-- #content -->
</div><!-- #content-container -->


		
		<div id="primary" class="widget-area" role="complementary">
					<ul class="xoxo">

			<li id="text-13" class="widget-container widget_text">			<div class="textwidget"><a class="twitter-timeline" href="https://twitter.com/FrndEnterprise" data-widget-id="274248392807415808">Tweets by @FrndEnterprise</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></div>
		</li>			</ul>
		</div><!-- #primary .widget-area -->

				<div id="secondary" class="widget-area" role="complementary">
			<ul class="xoxo">
					<li id="recent-posts-2" class="widget-container widget_recent_entries">		<h3 class="widget-title">Latest blog post</h3>		<ul>
					<li>
				<a href="http://www.ferndaleenterprise.com/2017/10/10/three-ferndale-residents-witness-vegas-slaughter/">Three Ferndale residents witness Vegas slaughter</a>
						</li>
				</ul>
		</li>		<li id="text-9" class="widget-container widget_text">			<div class="textwidget"><a href="http://ferndaleenterprise.com/awards"><img src="http://www.ferndaleenterprise.com/wp-content/uploads/2013/07/130723_nna2013_200_96.jpg"></a></div>
		</li><li id="nav_menu-4" class="widget-container widget_nav_menu"><div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-353"><a href="http://www.ferndaleenterprise.com/">Home</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-354"><a href="http://www.ferndaleenterprise.com/advertise/">Advertise</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-368"><a href="http://www.ferndaleenterprise.com/subscribe/">Subscribe</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-358"><a href="http://www.ferndaleenterprise.com/contact/">Contact</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-377"><a href="http://www.ferndaleenterprise.com/newsstands/">Newsstands</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-355"><a href="http://www.ferndaleenterprise.com/archives/">Archives</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-364"><a href="http://www.ferndaleenterprise.com/merchandise/">Merchandise</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-366"><a href="http://www.ferndaleenterprise.com/souvenir-edition/">Souvenir Edition</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-371"><a href="http://www.ferndaleenterprise.com/about/">About</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-356"><a href="http://www.ferndaleenterprise.com/awards/">Awards</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-360"><a href="http://www.ferndaleenterprise.com/history/">History</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-367"><a href="http://www.ferndaleenterprise.com/staff/">Staff</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-361"><a href="http://www.ferndaleenterprise.com/in-the-news/">In the news</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-363"><a href="http://www.ferndaleenterprise.com/jack/">Jack&#8217;s Corner</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1233"><a href="http://www.ferndaleenterprise.com/jack/jack-mays-editorial-cartoon-awards/">Awards</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-384"><a href="http://www.ferndaleenterprise.com/jack/gallery/">Gallery</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-365"><a href="http://www.ferndaleenterprise.com/podcast/">Podcast</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-357"><a href="http://www.ferndaleenterprise.com/blog/">Blog</a></li>
</ul></div></li><li id="search-3" class="widget-container widget_search"><form role="search" method="get" id="searchform" class="searchform" action="http://www.ferndaleenterprise.com/">
				<div>
					<label class="screen-reader-text" for="s">Search for:</label>
					<input type="text" value="" name="s" id="s" />
					<input type="submit" id="searchsubmit" value="Search" />
				</div>
			</form></li>			</ul>
		</div><!-- #secondary .widget-area -->
		
			</div><!-- #content-box -->

	<div id="footer" role="contentinfo">
		
<div id="footer-widget-area" role="complementary">

	<div id="first" class="widget-area">
		<ul class="xoxo">
			<li id="text-5" class="widget-container widget_text">			<div class="textwidget">P.O. Box 1066, Ferndale CA 95536 (all mail, please) • 207 Francis St. (no mail, please) • 707-786-3068 • fax 707-786-4311 • <a href="mailto:editor@ferndaleenterprise.us">editor@ferndaleenterprise.us</a></div>
		</li>		</ul>
	</div><!-- #first .widget-area -->

	<div id="second" class="widget-area">
		<ul class="xoxo">
			<li id="text-8" class="widget-container widget_text">			<div class="textwidget">Published every Thursday for 139 years</div>
		</li>		</ul>
	</div><!-- #second .widget-area -->

	<div id="third" class="widget-area">
		<ul class="xoxo">
			<li id="text-7" class="widget-container widget_text">			<div class="textwidget">Established 1878, Ferndale, California</div>
		</li>		</ul>
	</div><!-- #third .widget-area -->

	<div id="fourth" class="widget-area">
		<ul class="xoxo">
			<li id="text-6" class="widget-container widget_text">			<div class="textwidget">Member, California Newspaper Publishers Association, National Newspaper Association</div>
		</li>		</ul>
	</div><!-- #fourth .widget-area -->

</div><!-- #footer-widget-area -->
		<div id="colophon">
			<span class="generator-link"><a href="http://wordpress.org/" title="A Semantic Personal Publishing Platform" rel="generator">Proudly powered by WordPress.</a></span>
			Theme: Coraline by <a href="https://wordpress.com/themes/" rel="designer">WordPress.com</a>.		</div><!-- #colophon -->
	</div><!-- #footer -->

</div><!-- #container -->

	<div style="display:none">
	</div>
<script type='text/javascript' src='http://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201741'></script>
<script type='text/javascript' src='http://www.ferndaleenterprise.com/wp-includes/js/wp-embed.min.js?ver=4.7.6'></script>
<script type='text/javascript' src='http://stats.wp.com/e-201741.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:3.9.7',blog:'41701037',post:'1677',tz:'-7',srv:'www.ferndaleenterprise.com'} ]);
	_stq.push([ 'clickTrackerInit', '41701037', '1677' ]);
</script>
</body>
</html>